Behavior
When trying to create a folder in Box for Salesforce, the following error is received:

Cause
This is caused by the connection(s) between the Box Service account and/or Box User account no longer being valid and requires a reauthorization to reestablish connection.
Resolution
If this error occurs for all users*:
-
Go to Salesforce and login to the Salesforce admin account
-
Go to the + icon when you login and click Box Settings
-
Reauthorize the Box Service account with the correct credentials
If this error occurs for a single user*:
-
Go to Salesforce and login to your Salesforce account
-
Go to the + icon when you login and click Box Settings
-
Reauthorize the Box user account with the Box credentials for the user currently signed in to Salesforce.
After these steps are completed, try creating a folder; if the error persists, please submit a case here.
*We recommend these steps be done in a private browsing/incognito window
platform_swarm_kb