Zip download API behave incorrectly

New post



  • Rui Barbosa

    Hi Tatsuya,

    Please elaborate your question a bit more.

    Are you sure the JWT service user has access to the files and can actually download them?

    In the response you should get some status URL's, e.g.:


    What does your's say?

    It would also help if you tell us a bit more about your "app running API in cURL on Linux server"

    If I show you a python example, would that work for you?

    Do you prefer a bash box CLI script?

    Comment actions Permalink
  • TOMINO Tatsuya

    Hi Rui,

    Thanks for your reply.

    After I run the Create zip download API, I run the "download_url" from the response.

    Basically, the correct ZIP was downloaded, but there was a posting incident only once.

    I do not use the CLI. I use cURL directly in bash.

    for example:

    curl -i -s -m 300 --tlsv1.2 -X POST "" -H "Authorization: Bearer ${bearer}"
    DownloadapiUrl=`grep download_url ${ResponsefileName} | awk -F '["]' '{print $4}'`
    curl -f -s -m 300 --tlsv1.2 -X GET "${DownloadapiUrl}" -o

    * This server does not install a "jq" command

    Comment actions Permalink

Please sign in to leave a comment.