問題
Box Shieldのアクセスポリシーで [ユーザーの正当な理由を許可する] を有効にしています。
外部コラボレーションが制限されたコンテンツを、[ユーザーの正当な理由] を選択して共有しようとすると、「リクエストの実行中に問題が発生しました。 再度お試しください。」というエラーメッセージが表示されます。
根本原因
[ユーザーの正当な理由] オプションでは予備メールアドレスをサポートしていないため、 共有先に予備メールアドレスを指定した場合は、エラーが発生します。
解決方法
[ユーザーの正当な理由] オプションを使用する場合は、プライマリアドレスを使用してください。