Could not resolve dependency: npm ERR! peer axios@"^0.18.1" from box-ui-elements@12.0.0-beta.9 npm ERR! node_modules/box-ui-elements npm ERR!

回答済み
新規投稿

コメント

4件のコメント

  • 正式なコメント
    Alex Novotny

    Hello, 

    Is this happening with vs 13.0.0 too? It looks like the vs you are installing is a beta?

    Thanks, 

    Alex, Box Developer Advocate

    コメントアクション Permalink
  • Joseph Chung

    wYes it happens with v13 as well.  I've tried --force and --legacy.. nothing seems to resolve the depreciated dependencies. 

     

    npm ERR! code ERESOLVE
    npm ERR! ERESOLVE unable to resolve dependency tree
    npm ERR!
    npm ERR! While resolving: client@0.1.0
    npm ERR! Found: axios@0.21.4
    npm ERR! node_modules/axios
    npm ERR! axios@"^0.21.1" from the root project
    npm ERR!
    npm ERR! Could not resolve dependency:
    npm ERR! peer axios@"^0.18.1" from box-ui-elements@13.0.0
    npm ERR! node_modules/box-ui-elements
    npm ERR! box-ui-elements@"13.0.0" from the root project
    npm ERR!
    npm ERR! Fix the upstream dependency conflict, or retry
    npm ERR! this command with --force, or --legacy-peer-deps
    npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
    0
    コメントアクション Permalink
  • Alex Novotny

    Let me reach out to that team and report back! Thank you for bringing this up. 

    0
    コメントアクション Permalink
  • Alex Novotny

    Can you confirm what version of npm you are running?  You could consider using the --legacy-peer-deps flag like described here. We verified it works for running npm v6.4.13.

     

    Thanks, 

    Alex

    0
    コメントアクション Permalink

サインインしてコメントを残してください。