When attempting to obtain an enterprise/application token for a custom application using Server Authentication (JWT, Client Credentials Grant, App Token), the following error message is returned:
Status: 429 Too Many Requests
{"error": "temporarily_unavailable","error_description": "The server is currently unable to handle the request due to a temporary overloading of the server"}
Root Cause
The above error can occur when the primary admin of the enterprise exceeds approximately 1000 API calls per minute (more information here). If the primary admin hits the rate limit, then the service accounts of the same enterprise may hit this error upon token request.
Resolution
Retry the request after waiting after the amount of time specified by the retry-after
header.
platform_swarm_kb