Welcome to the new Box Support website. Check out all the details here on what’s changed.

App stopped working this AM - insufficient permission

New post



  • Emanuele Ghetti

    Same problem here.
    Have been using the endpoint "https://api.box.com/2.0/files/{file.id}/content" since February, never had any problem but since 4 days i now receive the "Access denied - insufficient permission" message

    Comment actions Permalink
  • Chris Whatley

    Resubmitting the app for authorization by our admin fixed it for me. Some bug on the box side. My app showed it was authorized already.

    Zero help from box support on this. No investigation. Very disappointing! I just tried this as a Hail Mary.

    I’d suggest you open a ticket with support on this even if reauthorization fixes it. Maybe someone will figure out that there is a systemic issue.

    Comment actions Permalink
  • Emanuele Ghetti

    Thanks Bro.
    That worked for me aswell


    I admit this is kind of disappointing. Basic authorization issue left unanswered for 4 days when such a simple workaround existed

    Comment actions Permalink
  • Alex Novotny

    Hi Folks!

    Thanks for posting about your issue. The developer forum is not meant to be used for urgent on demand support or production level problems. If you are looking for that, please file a support ticket. It will get routed to the appropriate team and triaged. 

    Happy coding! 

    Alex, Box Developer Advocate

    Comment actions Permalink

Please sign in to leave a comment.