Big Sur Update - Box Drive fails to load

New post



  • Pooja Nawathe

    Same problem. Box drive system extension does not work and there is no option for it to enabled.

    Comment actions Permalink
  • France

    Hi Neil, and Pooja!

    Welcome to the Box Community!

    Sorry to hear that you are experiencing this issue with Box Drive. There are a few things you can try to try to resolve this:

    If you are running Box Drive on a Mac device with Intel chipset here are a few this you can try to resolve this issue:

    • Double-check the extension hasn't been approved yet. In System Preferences > Security & Privacy > General there would be an "Allow" button in this case.
    • Restart the computer (without uninstalling)
    • Uninstall Box Drive, restart the computer, and re-install

    If you are on a Mac device with M1 chipset, you can follow the install instructions and download link for Box Drive available on our Community site at this link.

    If none of the steps shared here works for you, please go ahead and submit a ticket with Box Support team to further help look in looking into this.

    Thanks for your participation in the forum and let us know how else we can help!


    Comment actions Permalink
  • Duncan Drury

    This has happened each time I have updated macos Big Sur - 11.5.1 two weeks ago, and to 11.5.2 just now.  This is for an Intel Mac, not M1. No extension approval dialog is visible in System Preferences > Security & Privacy > General.

    A second reboot after the macos update completed resolved the issue for me.

    Comment actions Permalink
  • Virginia Gordon

    The above 3 bullet solution from France worked a treat. Now have Box worked on my Big Sur

    Comment actions Permalink

Please sign in to leave a comment.