問題
サードパーティ製の連携アプリからBoxへログインする際、アクセス許可の画面に遷移せず、[ファイル] へリダイレクトされる。
根本原因
Box APIを利用するサードパーティ製アプリ側で、認証時に適切なOAuth URL (account.box.com/api/oauth2) が使用されていない場合、Box Verified Enterpriseが有効な環境で認証フローが正しく実行されないことがあります。
解決方法
一時的な対応としては、認証URLを「app.box.com」などから「account.box.com」に手動で書き換えてから認証することで、正しい認証フローを実行できます。
恒久的な対応策としては、サードパーティ製アプリ側で適切な認証URLを使用するように対応いただく必要があります。