問題
Android端末でBox for Androidにサインインしようとすると、アプリ内ブラウザに「Chromeを利用できません。 ブラウザの証明書は動作しません。」と表示され、ログインできない場合があります。
この事象は、Intuneで管理されたワークプロファイルを使用しているAndroid端末で発生しています。
根本原因
この問題は、認証画面を開くために必要なChromeが、ワークプロファイル内で正しく使えない状態になっていると発生することがあります。
Box for Androidの認証では、Android上でChromeを使ってサインイン画面を開きます。
そのため、以下の場合、ブラウザの証明書やクライアント証明書が正しく動作せず、サインインに失敗することがあります。
- ワークプロファイル内にChromeがインストールされていない
- ワークプロファイル内のChromeが無効になっている
- MDM (モバイルデバイス管理) やアプリ保護ポリシーによってChromeの利用が制限されている
解決方法
以下の順に確認してください。
- ワークプロファイル内にChromeがあるか確認します
- Android端末で [設定] を開きます。
- [アプリ] を開きます。
- ワークプロファイル側のアプリ一覧を確認します。
- Chromeが表示されているか確認します。
- Chromeが有効になっているか確認します
- Chromeが表示されていても、無効になっている場合はサインインできないことがあります。
- Chromeのアプリ情報を開き、無効になっていないか確認します。
- 無効になっている場合は、有効に変更します。
- 管理ポリシーを確認します
- Chromeが見つからない場合や有効にできない場合は、組織の管理設定が影響している可能性があります。
- IT管理者は、Intuneや関連するアプリ保護ポリシー、端末管理ポリシーを確認してください。
- 特に、ワークプロファイル内でChromeのインストールや起動が制限されていないか確認します。
- 必要に応じてChromeを利用できる状態にします
- ワークプロファイル内にChromeが未導入の場合は、管理方法に沿って追加します。
- すでに導入済みの場合は、無効化や制限がかかっていない状態にします。