Current date\/time MUST be before the expiration date\/time listed in the 'exp' claim

回答済み
新規投稿

コメント

6件のコメント

  • Murtza

     

    This error happens when the Unix time on your local machine and the Box server are out of sync. 

     

    To fix this error, update the Unix time on your machine to match the Unix time from this site. Then retry your request to generate the App User access token.

     

    Please let me know if that fixes the error?

    0
    コメントアクション Permalink
  • StingLikeABee

    Thanks Murtza

     

    I think that might do the trick.  I checked and the one server in question seems to be drifting about 45 seconds off from all of our others.  I've adjusted and will keep watch this week but my guess is that you nailed it.

     

     

    0
    コメントアクション Permalink
  • romanApll

    Hello. I keep getting the same error nspite of time synchronization with time,gov, windows synchronization and etc. Do you have a normal way to access your api without this time checkings? Or can you guarantee that you sever time is correct?

    0
    コメントアクション Permalink
  • dwrober

    I am having this issue currently as well on my local machine.  As far as I can tell, the current date/time is accurate.

    0
    コメントアクション Permalink
  • dave_eos

    We're having this problem now after deploying. We deploy to Heroku. Maybe Box can sync its time with their servers instead?

    0
    コメントアクション Permalink
  • dave_eos

    FYI, we are still having this problem. This is a quite a lot of trouble for us and no resolution. Must Box be so strict?

    0
    コメントアクション Permalink

サインインしてコメントを残してください。