Issue
When logging in to Box via a third-party app, the process is redirected to All Files instead of the access permission screen.
Root Cause
If a third-party app using the Box API does not use the correct OAuth URL (account.box.com/api/oauth2) during authentication, the authentication flow may fail in environments where Box Verified Enterprise is enabled.
Resolution
As a temporary workaround, you can run the correct authentication flow by manually changing an invalid authentication URL, such as “app.box.com,” to “account.box.com” before performing authentication.
As a permanent solution, request the third-party app developer to use the correct authentication URL.