Issue
In an active or completed Box Relay workflow, the history of an assigned task no longer appears in the file’s activity list.
Root Cause
This behavior could occur when a Box Relay workflow uses File Request as the trigger and the same task is assigned to multiple files during the action.
When a single task is assigned to multiple files, deleting any one of those files causes the task history to disappear from the activity list of all associated files.
Resolution
Use the User Activity report to identify the files to which the task was assigned and determine which file was deleted. Restoring the deleted file will make the task history appear again in the activity list for all associated files.