現象
ユーザーがBox Mobileアプリ (Box for EMM、Box for iPhone/iPad、またはBox for Android) にログインすると、[Box管理者によりIntuneモバイルアプリケーション管理が必須となっています。] というメッセージが表示される場合があります。
根本原因
このメッセージが表示されるのは、管理者が設定したIntuneモバイルアプリケーション管理 (MAM) の保護要件をBox Mobileアプリが満たしていない場合です。
Intune MAMによる保護へのBox Mobileアプリの登録を必須にする設定を管理者が有効にすると、ユーザーは、Intune MAMポリシー (別名、アプリ保護ポリシー) で保護されていないBox Mobileアプリにログインできません。
環境
この記事は、Intune MAMが必須のBox Mobileアプリを対象としています。 この要件は、MDMを使用する場合もしない場合も適用できます。
Box for EMM (MDMを使用するIntune MAM)
Microsoft Intune管理センターのアプリ構成ポリシーで、[Intune Enterprise] の値が1に設定されています。
Box for iOS/Android (MDMを使用しないIntune MAM)
Box管理コンソールの [モバイル] タブで、[Intuneモバイルアプリケーション管理 (Intune MAM) を有効化する] が有効になっています。
以下のトラブルシューティング手順を実行する前に、該当する環境を確認してください。 Box for EMMと標準のBox Mobileアプリでは、構成の確認方法が異なります。
解決方法
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Intune MAMの設定を確認する:
- Intune MAMが正しく設定され、Box Mobileアプリに適用されていることを確認します。
- アプリ構成ポリシーとアプリ保護ポリシーの両方が設定ガイドに従って構成されていることを確認します。
- そのユーザーにポリシーが割り当てられていることを確認します。
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構成を確認する:
- アプリ構成ポリシーに含まれるキーと値のペアに、誤字や欠落がないかどうか確認します。 設定ガイドを参照してください。
- キーは通常、大文字と小文字が区別され、完全に一致している必要があります。 キー/値の末尾にスペースがあると、問題を引き起こす可能性があります。
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MicrosoftアカウントのUPNとBoxユーザーのログイン用メールアドレスが一致していることを確認します。 これは、アプリ構成ポリシーでuserprincipalnameが設定されていない場合 (Box for EMM)、またはユーザーがSSOを使用せずにサインインする場合 (Box for iPhone/iPadおよびBox for Android) に非常に重要です。
注:SSOを使用しないサインイン: Boxへのサインイン後、モバイルアプリは、Boxユーザーのログイン用プライマリメールアドレスを使用してそのユーザーをIntune MAMに登録します。 このメールアドレスが、Intune登録時に使用されたMicrosoftアカウントのUPNと異なる場合、ユーザーはBoxへのサインインを完了しても、[Box管理者によりIntuneモバイルアプリケーション管理が必須となっています。] というメッセージが表示され、ブロックされたままになる可能性があります。
SSOサインイン: Boxのログインサービスは、MSAL経由でのサインイン時に、ユーザーのEntra UPNをモバイルアプリに提供します。 その後、アプリはそのMicrosoft IDを使用してユーザーをIntune MAMに登録します。 このフローでは、Boxのログイン用プライマリメールアドレスとMicrosoft UPNの照合を別途行う必要はありません。
- アプリ構成ポリシーに含まれるキーと値のペアに、誤字や欠落がないかどうか確認します。 設定ガイドを参照してください。
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ポリシーステータスを確認する:
- Microsoft Intune管理センターで、ポリシーステータスを確認します。 Microsoftのトラブルシューティングガイドに記載されている手順に従ってください。
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サポートチケットを送信する:
- 問題が解決しない場合は、次の情報を記載したチケットをBoxサポートに送信してください。
- 影響を受けたユーザーのログインアドレス
- ログインに失敗した期間
- ログイン操作を録画したビデオ (iOS向けの手順: Appleサポート)
- Intuneのアプリ構成ポリシーのスクリーンショット (Box for EMMを使用している場合)
- Microsoft Intune管理センターのポリシーステータスを示すスクリーンショット
- 影響の範囲 (問題が特定のユーザー/デバイスに影響しているのか、すべてのユーザー/デバイスに影響しているのか)
- 問題が解決しない場合は、次の情報を記載したチケットをBoxサポートに送信してください。
結果
- [Box管理者によりIntuneモバイルアプリケーション管理が必須となっています。] メッセージが表示されることなく、Box Mobileアプリにログインできるようになります。
- アプリは、管理者の設定に従ってIntune MAMによって保護されます。