問題
iOSのファイル AppからBoxにアクセスしようとした際、「管理者がBoxのアプリ内パスコードを要求している間は、アカウントでのファイル Appの機能の仕様は制限されています」というエラーメッセージが表示され、操作が中断されることがあります。
根本原因
この問題は、Box管理コンソールの設定で [Box Mobileアプリのパスコード設定] がパスコードロックを要求する設定になっている場合に発生します。 Box for iOSアプリ側でパスコード認証が完了していない、またはこのセキュリティ制限が有効な状態では、ファイル App経由でのアクセスが制限される仕様となっていることが原因です。
参考: Boxとファイル Appの統合に関する既知の制限事項
解決方法
管理者が以下の手順で設定を変更することで、ファイル Appからのアクセスが可能になります。
ステップ1: 管理コンソールへのアクセス
- Boxの管理者アカウントでログインし、[管理コンソール] を開きます。
- メニューから [Enterprise設定] を選択します。
ステップ2: モバイル設定の変更
- [モバイル] タブをクリックします。
- [Box Mobileアプリのパスコード設定] セクションを確認します。
ステップ3: 設定の適用
- [パスコードロックを必須にする] の項目を [強制適用しない] に変更します。
- 画面の [保存] ボタンをクリックして設定を反映させます。