When logging into the Box mobile app (Box for EMM, Box for iPhone/iPad, Box for Android), a user might see the message "Intune Mobile Application Management is required by your Box Administrator."
Root Cause
The above message gets displayed because the Box mobile app doesn't meet the requirement of Intune MAM protection.
When the admin turns on the setting that requires the Box mobile app be enrolled into Intune MAM protection, then users will not be able to login on the Box mobile app that is not protected by Intune MAM policies (aka app protection policies).
Environment
Box mobile app where Intune MAM is set to be required. Intune MAM requirement can be enforced on the Box mobile app that is provisioned with MDM and without MDM via the following settings respectively:
Box for EMM (Intune MAM with MDM)
The value for "Intune Enterprise" is set to 1 on app configuration policy via Microsoft Intune admin center.
Box for iOS/Android (Intune MAM without MDM)
The toggle for "Intune Mobile Application Management (Intune MAM)" is enabled on "Mobile" tab of Admin Console.
Troubleshooting Steps
Please check if the Intune MAM is set up correctly and is applied to the Box mobile app.
- Please make sure that both app configuration policy and app protection policy are configured (per the setup guide), applied to the Box mobile app and assigned to the user.
- Mistakes in configuration can cause issue. For e.g. typo/missing those key value pairs in app configuration policy can disrupt Intune MAM protection for Box for EMM.
- The login address of Microsoft account must match the primary login address of Box account (as per this article)
If you don't see any mistakes in configuration/user account you are using, the next thing to check is the policy status on Microsoft Intune admin center.
- The following article from Microsoft contains the steps to do this:
https://learn.microsoft.com/en-us/troubleshoot/mem/intune/app-protection-policies/troubleshoot-app-protection-policy-deployment
If the above steps don't help resolve the issue, Please submit a ticket and include the following with the following information:
- Login address of the affected user
- Timeframe of failed login
- Video recording of login (Steps for iOS: https://support.apple.com/en-us/102653)
- Screenshot of Intune app configuration policy (if using Box for EMM)
- Screenshot that shows the policy status on Microsoft Intune admin center
- Scope of impact (whether the issue happens on a specific user/device or across all users/devices)