Issue
Attempting a folder operation results in an error.
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When creating/deleting a folder
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When copying a folder
Click Details -
When moving a folder
Click Details
Root Cause
One of the following can cause this error:
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The API has locked the folder deletion or movement.
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Another folder operation is interfering with the process.
If a large-scale folder operation is in progress, actions on the source and destination folders, as well as their parent and subfolders, are restricted.
To identify the cause of the error, follow the steps described below.
To obtain network logs, refer to: https://support.box.com/hc/en-us/articles/360043696054-How-to-Generate-Network-Captures-for-Troubleshooting
When the API has locked the folder deletion or movement:
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When deleting a folder
The following code appears for the “delete” request in the network log.
{
"status": 403,
"errorCode": "freezeLocked",
"data": "This folder cannot be moved or deleted because it has been locked to prevent such operations."
}
-
When moving a folder
The error details show the message: “This folder cannot be moved or deleted because it has been locked to prevent such operations.”
If another folder operation is interfering:
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When creating a folder
The following code appears for the “create” request in the network log.
{
"status": 400,
"errorCode": "createFolderGeneralError",
"data": {
"message": "Folder is locked by another operation."
}
}
-
When deleting a folder
The following code appears for the “delete” request in the network log.
{
"status": 409,
"errorCode": "operationInProgressError",
"data": "A conflicting operation is being performed on one or more of the selected items."
}
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When copying a folder
The error details show the message: “You cannot copy this folder because either the source or destination folder is currently locked by another operation.” -
When moving a folder
The error details show the message: “You cannot move this folder because either this folder or the destination folder is locked by another operation.”
Resolution
When the API has locked the folder deletion or movement:
Check the folder status via the Folder Lock API and unlock the folder as necessary. For details of the Folder Lock API, refer to: https://developer.box.com/reference/resources/folder-lock/
If another folder operation is interfering:
The issue depends on the progress of the large-scale folder operation causing the error. If you are still unable to perform any operations after 24 hours, please contact our customer support.