Issue
When a user attempted to generate an App Diagnostics report by selecting an app from Developer Console > My Platform Apps and navigating to the App Diagnostics tab, the following error message appeared: “Something went wrong. Report did not initiate.” As a result, the report could not be generated.
Root Cause
In the following cases, the user attempting to generate an App Diagnostics report does not have permission to create content, and as a result, the report cannot be generated.
-
In the Admin Console > Enterprise Settings > Content & Sharing tab, the checkbox for "Only admins can create and delete first-level folders, files, and bookmarks" under Content Creation is selected.
-
The Box Reports folder does not exist within the user’s All Files.
Resolution
Add an admin or co-admin as a collaborator to the target app, and request that they generate an App Diagnostics report.