Issue
“Oops” errors are observed in the Box Folder Component in a Salesforce Sandbox after a refresh.
Cause
The Box Folder/Salesforce Record relationship is maintained by an object in Salesforce called a FRUP. A single FRUP record includes a Box folder ID and its associated record ID in Salesforce. It also keeps track of individual users (Box and Salesforce), and their access to the folder/record relationship.
In the course of a refresh FRUP objects are created in a sandbox with values for salesforce record ID’s which exist in the production org. This causes unexpected behavior in the Box Folder Component which is present on records in the Sandbox.
Resolution
Although the integration does not include a feature which would automate the creation of FRUPs which would relate to their production record counterparts, it does include a feature that will clear out all existing Box Data for a sandbox. While this does not provide a perfect match to the data which exists in your production org, it will allow you to continue to test he functionality of the Box for Salesforce integration in a Sandbox.
In order to delete all Box setting data from a sandbox, navigate to the Box Settings tab > Advanced Setup > Advanced Settings > Click on Delete All Box Data in this Sandbox button.