Grant credentials are invalid

New post

Comments

6 comments

  • Kourtney

    Hey Michael, 

    There is a bug I've reported to our engineering team that it looks like you've encountered. I can take care of this on the backend for you and get you up and running. Can you please tell me what the desired application access is for this application? You can take a look at the options in the configuration tab of the Developer Console: App Only or App + Enterprise. 

    Best,

    Kourtney, Box Developer Advocate

    0
    Comment actions Permalink
  • Michael Chirlin

    I would like to have enterprise access for these credentials.  

    0
    Comment actions Permalink
  • Michael Chirlin

    I was able to get past the error above by clicking App + Enterprise and then requesting authorization of the app in the Dev console and granting in the Admin console.

    However, when I get an access token and then request the items in a folder, e.g. 127335345385, I am receiving a 404 when I would expect the service account to be able to access this folder and its child items:

    {
    "type": "error",
    "status": 404,
    "code": "not_found",
    "context_info": {
    "errors": [
    {
    "reason": "invalid_parameter",
    "name": "folder",
    "message": "Invalid value 'd_127335345385'. 'folder' with value 'd_127335345385' not found"
    }
    ]
    },
    "help_url": "http://developers.box.com/docs/#errors",
    "message": "Not Found",
    "request_id": "k3y05fgq2bqhdfnp"
    }
    0
    Comment actions Permalink
  • Vivek Sunder

    I am running into this as well. Is this still a bug?

    0
    Comment actions Permalink
  • Kevin Cho


    Hi Kourtney,

    Would you mind having a look at our app to see the bug is affecting us? We are having the same issue.
    - App + Enterprise

    - client ID:1ef9ltqp9f9ftv4dydqjius4w20072rc

     

    Thanks.

     

    0
    Comment actions Permalink
  • Ondrej Vonsovsky

    Gosh, this product is a joke. Spent hours on forums to solve these random problems and it's either "sorry a bug" or "we changed something in our database, can yout try now?" everytime. Highly unprofessional environment and far from usable.

    0
    Comment actions Permalink

Please sign in to leave a comment.