enterprise ID

New post

Comments

9 comments

  • Brent

    Hi  - Sounds like you're on your personal account settings, not the Enterprise settings. To reach the Enterprise settings view, click the "Admin Console" link from the top of your Box account. Then choose the Gear icon / Enterprise settings. Alternatively, this is a direct link to that page.

    0
    Comment actions Permalink
  • Box Product Support

    Hi Brent, thank you for the prompt reply. I tried the provided the
    solution however, can't see the enterprise Id and instead I got to "custom
    setup" tab , please see attachment below for further clarification.


    0
    Comment actions Permalink
  • d3vtoolsmith

    Did you find it? Same problem here...

    0
    Comment actions Permalink
  • Murtza

     Your Enterprise ID will be listed on this page: 

    https://app.box.com/master/settings

     

    Please let me know if you are not able to access that page?

     

     

     

    0
    Comment actions Permalink
  • d3vtoolsmith

    It turned out to be visible only on main admin's Settings Page. Co-admins (which my account is) cannot even see this page and so enterprise-ID is impossible to find. I got it from our main admin.

    0
    Comment actions Permalink
  • Murtza

     Thanks for the feedback. I will clarify this in our documentation.

    0
    Comment actions Permalink
  • martin_dev

     This does not appear to have been clarified in the docs yet.

    This page talks about where to find it, but doesn't mention that only the primary admin can see it: https://docs.box.com/v2.0/docs/app-users#section-1-request-an-enterprise-token

    This page mentions enterprise_id without any help in finding it, and so needs a link (perhaps to my previous link above): https://docs.box.com/v2.0/docs/app-auth#section-6-constructing-the-claims

    0
    Comment actions Permalink
  • martin_dev

    Also, is this enterprise access token only intended to be used by apps written by a company for their own Box enterprise? That is, if I write an app that is intended to be made available to multiple enterprises & perform something using a service account (which I believe requires an enterprise access token), is that not an intended use, or do I have to have some UI somewhere in my app that asks the admin to enter their enterprise ID?

    I assume that that's not an intended use, as there isn't a programmatic way to get hold of the enterprise ID.

    0
    Comment actions Permalink
  • NPapa

    There is a "trick" to getting on that page even if you're only a co-admin. Using Chrome or any other browser that supports modifying page elements...

     

    • Go to the Enterprise Settings page
    • Right click on any of the menu items (i.e. Custom Setup) and choose Inspect
    • You should see the HTML of the page
    • Look for 
      
      
    • Account Info
    • Delete the word hidden so the first part is like
      
      
    • You should see a new menu item appear called Account Info. Click on it and you now can see the Enterprise ID along with some other details about your Enterprise Account 🙂  
    0
    Comment actions Permalink

Please sign in to leave a comment.