Issue
In Box for Salesforce, clicking the Download button does not start downloading.
Root Cause
This may occur if the custom sub-domain settings are not correct in Salesforce integration.
Resolution
Perform the following steps to check whether a Box custom sub-domain is correctly configured in Box for Salesforce.
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In Box for Salesforce, click Setup.
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In the Quick Find box, type "Custom Setup."
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Select Custom Setup.
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In the Folder Details row, click Manage.
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In Folder Details, locate root_url_override.
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In case root_url_override is configured with wrong subdomain, delete root_url_override.
- Re-authenticate(Sign In) from Box Settings
If the above steps do not help, please submit a ticket here and reference this article with below information.
- Network log for downloading (Har, Console)
* How to Generate Network Captures for Troubleshooting – Box Support - Timestamp of the operation
- Operating user