Box for Salesforce users may see the error message "Folder for the request cannot be created/found. Please check Configuration" in the red banner when attempting to create a folder within Salesforce record page:
Root Cause
This error can happen when the Box service account is not authorized. This can also happen if the object level folder is not created or not mapped correctly to the corresponding Salesforce object.
Resolution
To resolve this error, first try re-authorizing the Box service account by following the steps in Box for Salesforce - "Your Connection To Box Is No Longer Valid".
If that doesn't resolve the issue, then follow the below steps to check/correct the mapping of the object-level folder.
Note: The following steps assume that the error occurred with the record under the object titled "行動" (per the above screenshot).
On Box side
- On browser (private mode), log into Box as the Box service account.
- Navigate to Salesforce root folder, and check if the object-level folder exists for the problematic object (i.e. check if the folder titled "行動" exists under the Salesforce root folder).
- If it exists, note down the ID of that folder (the ID is the sequence of the numbers at the tale of the url that appears on the address bar when you open that folder). In this example, it's "219853890631"
On Salesforce side
- Click on Setup at the top right corner
- Enter Custom Settings in the Quick Find box,
- Select Custom Settings.
- From the Custom Settings page, click "Manage" next to the Folder Details row
- You'll see the list of objects. Check if the item that corresponds to the problematic object exists (In this example, look for "行動" in the list).
- Fix the mapping of the object between Box and Salesforce by matching the value of the object on Salesforce with the ID of the folder on Box you found at step 3 ("219853890631" in this example). With the above example,
- If "行動" object exists under "Folder Details", click on that object, check the value for "FolderId" of that object and note it down (for backup). If the value is different from the ID of the folder on Box ("219853890631" in this example), then select "Edit", replace it with that ID and "Save".
- If it doesn't exist (although you see "行動" folder on Box at step 3 above), then manually create "行動" by clicking "New", name it "行動" and insert the ID of the folder in "FolderId" field.
If the above steps doesn't resolve the issue, please submit a case here. Please provide the screenshot of the error and the "Folder Details" page of the problematic object as well as the details (whether the object folder exists, "FolderId" before and after editing, etc.)