Box for Salesforce users may see the error message "You can not set the Box service account to the same account as an existing user." when attempting to login as Box Service Account through Box Settings tab:
Root Cause
The error occurs when you attempt to log in as a Box Service Account by using a Box account that is already logged in as a Box User Account for the Box for Salesforce integration. The Box Service Account and User Account must be discrete accounts. You cannot log in with the same account in both places.
Resolution
To resolve this error, ensure that you are using a different Box account for each Salesforce account. If the Box account you intend to use as the Box Service Account is already being used as a Box User Account, you will need to log out of that user account.
Here are a few ways to achieve this:
- Re-authorize with a Different Box Account:
- Log in as a different Box account via "Log In as a Box User" to free up the account for use as the service account.
- Clear Existing Association:
- Follow the steps outlined in this article to run the deleteUserAssociation method through the Developer Console and clear the existing association between your Salesforce account and your Box account.
After following these steps, you should be able to successfully sign in as the Box Service Account.