問題
管理者の予備メールアドレスをプライマリメールアドレスに変更したいのですが、 [アカウント設定] > [アカウント] タブで確認できる管理者の予備メールアドレスに、[プライマリに変更] が表示されません。
根本原因
以下の場合、ユーザーによるプライマリメールアドレスの変更が防止されるため、[プライマリに変更] が表示されません。
- [管理コンソール] > [Enterprise設定] > [ユーザー設定] タブで [SSO必須モード] が有効になっている
- [管理コンソール] > [Enterprise設定] > [セキュリティ] タブ > [サインアップとログイン] > [ユーザーのメールアドレス/ログイン] にある [ユーザーがプライマリメールアドレスを変更できないようにする] が有効になっている
解決方法
[プライマリに変更] を表示するには、[SSO必須モード] と [ユーザーがプライマリメールアドレスを変更できないようにする] を一時的に無効にします。
予備メールアドレスをプライマリメールアドレスに変更する場合は、以下の手順を行ってください。 あらかじめ、予備メールアドレスの確認が完了している必要があります。
- [管理コンソール] > [Enterprise設定] > [ユーザー設定] タブで [SSO必須モード] を無効にします。
- [管理コンソール] > [Enterprise設定] > [セキュリティ] タブ > [サインアップとログイン] > [ユーザーのメールアドレス/ログイン] にある [ユーザーがプライマリメールアドレスを変更できないようにする] を無効にします。
- [アカウント設定] > [アカウント] タブに表示されるメールアドレスのうち、予備メールアドレスの部分に表示される [プライマリに変更] をクリックします。
- 変更が必要な場合は、IdP側のメールアドレスも同様に変更します。
- 新しく設定したプライマリメールアドレスでSSOログインが成功することを確認します。
- 必要な場合は、手順1を参考に [SSO必須モード] を有効にします。
- 必要な場合は、手順2を参考に [ユーザーがプライマリメールアドレスを変更できないようにする] を有効にします。