When attempting to open a file on your desktop through Box Edit on Windows or macOS, you may see the "Open" button missing or greyed out:
Common Causes
"Open" button can be missing/greyed out for any of the following reasons:
- Box Edit is not enabled for the user.
- The user does not have the permission to edit the file.
- Box Edit cannot determine the default application for the file.
- Owner of the file is not set to "Active" status in Admin Console -> Users & Groups
- The file type is blocked for editing via Box Edit. The file type that is not supported for editing with Box Edit includes script files (such as .py, .sh and .bat) and executable files (such as .exe and .dll).
Troubleshooting Steps
- Make sure that Box Edit is enabled for the user via App Center (https://app.box.com/services/box_edit).
- Make sure that your account has the permission to edit the file. You need to have the "Viewer Uploader" role or above to edit the file. For more details about permission, please refer to Understanding Collaborator Permission Levels.
- Verify that Box Tools is installed and its process are running (Please refer to How to Check if Box Tools is Installed and Running for details).
- Verify that the you have the application installed on your device that is associated with the file type you are trying to use.
- If "Open" button is still missing/greyed out, please open up a case with our support team and provide the following information:
- Network Capture - You'll want to make sure you log into Box, start the capture and then refresh your browser!
- Box Edit logs
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Answers to the following questions:
- Is it happening to all users?
- Have you tried a different network? Do you get the same issue?
- Is it happening on all browsers?
- Please include a screenshot of your task manager showing the two processes running (Box Edit and Box Edit Local Com Server).
- Please include a screenshot of your control panel to ensure Box tools is installed.