Issue
Attempts to log in to Box for iOS result in the following message, and login fails:
“Your admin has restricted the use of this application. Please contact your admin to authorize this device.”
Root Cause
This issue arises when the number of devices a user can log in with is restricted by the "Device Pinning" feature in the Admin Console. This message appears when an attempt is made to log in to Box for iOS exceeding the configured device limit.
Resolution
Admin actions are required to check the device limit configured for each user with the "Device Pinning" feature and unassign a device.
Proceed with steps below.
- Log in to Admin Console with admin permissions.
- Open Enterprise Settings and navigate to the Device Protection tab.
- Check the number of devices the user has logged in with in the Application Usage section.
- If the number of devices has reached the limit, unassign any unnecessary devices.
- Have the user try logging in to Box for iOS again.
If the issue persists even after following the above steps, contact Box support with the following information:
- Device model, OS version, and Box for iOS app version of the affected user
- Email address used by the user when the issue occurred
- A screenshot of the error
- Timestamp when the error occurred