Issue
In environments with Device Trust enabled, attempts to log in to Box fail with the screen “Problem Determining Device Security.”
Root Cause
The Box Tools process may not have started correctly.
Resolution
Check the points below from (1) through (3) in order.
If the issue is not resolved, proceed to the next step.
(1) Open Task Manager and verify that the following two processes are running
- Box Edit
- Box Local Com Server
(2) Update Box Tools to the latest version
Update Box Tools by following the steps below:
- Use the Box Edit Cleaner script (https://cloud.app.box.com/v/BoxEditCleaner) to uninstall Box Tools. You can find "READ ME FIRST" file in each directories. If you are unsure which installer was used for the previous version, run each cleaner script and restart the operating system (OS) after each one.
- Install the Box Tools installer with admin permissions.
- Restart the OS.
(3) If the issue persists after updating Box Tools to the latest version
Collect the network log and Box Edit debugging log, and then contact Box Support.
For instructions on how to collect debugging logs, refer to the support article below:
- https://support.box.com/hc/en-us/articles/360043696054-How-to-Generate-Network-Captures-for-Troubleshooting
- https://support.box.com/hc/en-us/articles/360043692654-Collecting-Box-Edit-Logs