Box for SalesforceユーザーがSalesforceレコードページ内でフォルダを作成しようとすると、赤いバナーに「リクエストのフォルダを作成できないか、見つけることができません。 構成を確認してください」というエラーメッセージが表示される場合があります。
根本原因
このエラーは、Boxサービスアカウントが承認されていない場合に発生することがあります。 また、オブジェクトレベルのフォルダが作成されていない場合や対応するSalesforceオブジェクトに正しくマッピングされていない場合に発生することもあります。
解決方法
このエラーを解決するには、まず、Box for Salesforce - Your Connection To Box Is No Longer Valid (Boxへの接続が有効ではなくなりました) の手順に従って、Boxサービスアカウントを再承認してみてください。
問題が解決しない場合は、以下の手順に従ってオブジェクトレベルのフォルダのマッピングを確認/修正してください。
注: 以下の手順では、「行動」というオブジェクトの下にあるレコードでエラーが発生したことを想定しています (上のスクリーンショットを参照)。
Box側での手順
- ブラウザ (プライベートモード) で、BoxサービスアカウントとしてBoxにログインします。
- Salesforceルートフォルダに移動し、問題のあるオブジェクトにオブジェクトレベルのフォルダが存在するかどうかを確認します (つまり、Salesforceルートフォルダに「行動」というフォルダが存在するかどうかを確認します)。
- 存在する場合は、そのフォルダのIDを書き留めます (IDは、フォルダを開いたときにアドレスバーに表示されるURLの末尾にある連続した数字です)。 この例では、「219853890631」になります。
Salesforce側での手順
- 右上にある [Setup (設定)] をクリックします。
- [Quick Find (クイック検索)] ボックスに「カスタム設定」と入力します。
- [Custom Settings (カスタム設定)] を選択します。
- [Custom Settings (カスタム設定)] ページで [Folder Details (フォルダ詳細)] 行の横にある [Manage (管理)] をクリックします。
- オブジェクトの一覧が表示されます。 問題のあるオブジェクトに対応する項目が存在するかどうかを確認します (この例では、一覧で「行動」を探します)。
- Salesforce上のオブジェクトの値と手順3で確認したBox上のフォルダのID (この例では「219853890631」) を一致させて、BoxとSalesforceの間のオブジェクトのマッピングを修正します。 上記の例では、以下を実行します。
- [Folder Details (フォルダ詳細)] に「行動」オブジェクトが存在する場合は、オブジェクトをクリックして、そのオブジェクトの [FolderId (フォルダID)] の値を確認し、(バックアップのために) その値を書き留めます。 値がBox上のフォルダのID (この例では「219853890631」) と異なる場合は、[Edit (編集)] を選択し、値をそのIDに置き換えて、[Save (保存)] を選択します。
- (上記の手順3でBox上に「行動」フォルダが見つかる場合でも)「行動」オブジェクトが存在しない場合は、手動で「行動」オブジェクトを作成します。それには、[New (新規)] をクリックして、「行動」という名前を付け、[FolderId (フォルダID)] フィールドにフォルダのIDを挿入します。
上記の手順で問題を解決できなかった場合は、英語でケースを送信 してください。 エラーおよび問題のあるオブジェクトの [Folder Details (フォルダ詳細)] ページのスクリーンショットのほか、詳細 (オブジェクトレベルのフォルダが存在するかどうかや編集前と編集後の [FolderId (フォルダID)] など) を提出してください。
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