SalesforceレコードでBoxフォルダにアクセスしようとすると、次のエラーが表示されます。
Sorry, there was an issue with processing this request. (リクエストの処理中に問題が発生しました。)
Unable to create collaboration: Unable to collaborate user on record - Details: Error making collaboration request to Box - Response: (Not Found) (コラボレーションを作成できません: レコードでユーザーをコラボレートできません - 詳細: Boxへのコレボレーションリクエストの生成エラーです - 応答: (見つかりません))
{
"type": "error",
"status": 404,
"code": "not_found",
"context_info": {
"errors": [
{
"reason": "invalid_parameter",
"name": "item",
"message": "Invalid value 'd_4897007345'. 'item' with value 'd_4897007345 not found"
}
]
},
"help_url": "http://developers.box.com/docs/#errors",
"message": "Not Found",
"request_id": "10431564765630e78da776b"
}
原因
このエラーには、以下の2つの原因が考えられます。
- 特定のSalesforceレコードに関連付けられているBoxフォルダが削除されたか、存在しない。
- Boxユーザーが削除され、再作成された。
解決方法
Boxユーザーが削除されて再作成されている場合、このエラーを解決するには、こちらの記事の手順に従って、古いBoxユーザーとレコードフォルダの関連付けを削除します。
1つ目のシナリオが原因の場合にこのエラーを解決するには、以下の手順に従います。
- こちらの手順に従い、FRUPレポートをエクスポートします。
- FRUPレポートで、上記のエラーが発生しているレコードのIDを含む行 (複数の可能性もあります) を探します。
- その行の「Folder ID (フォルダID)」列で、該当するレコードにマッピングされているフォルダのIDを確認します (この例では、上記のエラーメッセージ/スクリーンショットのとおり「4897007345」になります。 「e」と表示される場合もあります)。このエラーが返されるのは、このIDのフォルダがBoxに存在しないため、Box for Salesforce統合がこのフォルダを検出できないことが原因です。
- このエラーを解決するには、以下のいずれかを実行します。
- Boxウェブアプリで、Boxサービスアカウントのごみ箱からフォルダ (この例の場合は「4897007345」) を復元します。
- (フォルダが完全に削除されているか「Folder ID (フォルダID)」列に「e」のような無効な値が含まれているため) フォルダを復元できない場合は、このフォルダIDが設定されたFRUPレコードを削除できます。 FRUPレコードを削除した後、Box埋め込みセクションからフォルダの再作成を試すことができます (これにより、新しいフォルダIDで新しいFRUPレコードが自動的に作成されます)。
platform_swarm_kb