Box for Salesforceユーザーが [Box設定] タブからBoxサービスアカウントとしてログインしようとすると、「You can not set the Box service account to the same account as an existing user. The current user using these credentials is {Salesforce User Name} (Boxサービスアカウントを既存のユーザーと同じアカウントに設定することはできません。これらの資格情報を使用している現在のユーザー: {Salesforceユーザー名})」というエラーメッセージが表示される場合があります。
根本原因
このエラーは、すでにBox for Salesforce統合のBoxユーザーアカウントとしてログインしているBoxアカウントを使用してBoxサービスアカウントとしてログインしようとした場合に発生します。 BoxサービスアカウントとBoxユーザーアカウントは別々のアカウントである必要があります。 両方に同じアカウントでログインすることはできません。
解決方法
このエラーを解決するには、各Salesforceアカウントに異なるBoxアカウントを使用していることを確認してください。 Boxサービスアカウントとして使用するBoxアカウントが、すでにBoxユーザーアカウントとして使用されている場合は、そのユーザーアカウントからログアウトする必要があります。
以下に、これを行う方法をいくつか示します。
- 異なるBoxアカウントで再承認する:
- エラーメッセージに示されたユーザーを使用して、Salesforceにログインします。 その後、[Boxユーザーとしてログイン] を使用して別のBoxアカウントとして再承認し、サービスアカウントとして使用するためにそのアカウントを解放します。
- 既存の関連付けを解除する:
- エラーメッセージに示されたユーザーを使用して、Salesforceにログインします。 その後、こちらの記事で説明されている手順に従い、開発者コンソールからdeleteUserAssociationメソッドを実行して、SalesforceアカウントとBoxアカウント間の既存の関連付けを解除します。
上記の手順に従うと、Boxサービスアカウントとして問題なくサインインできるようになります。
platform_swarm_kb