動作
レコードページ、アプリページ、画面フロー、その他のカスタム埋め込みウィジェット上で、Box Embed Lightningコンポーネントを介してSalesforceにBoxコンテンツを読み込んだ際に、接続エラーが表示され、Boxコンテンツが読み込まれない場合があります。
よく見られる2つのエラーメッセージを以下に示します。
a. 「Unable to resolve the server's DNS address (サーバーのDNSアドレスを解決できません)」
b. 「{0}{1}app.box.com's server IP address could not be found ({0}{1}app.box.comのサーバーIPアドレスが見つかりませんでした)」
原因
a. 「Unable to resolve the server's DNS address (サーバーのDNSアドレスを解決できません)」
[Box設定] ページの [Box Enterpriseのサブドメイン] が正しくありません。 この値には、ドメイン全体ではなく、Box URLのサブドメイン部分のみを指定する必要があります。
b. 「Server IP address could not be found (サーバーIPアドレスが見つかりませんでした)」
Box Enterpriseのサブドメインの統合への適用が完了していません。 ブラウザは、実際のBox URLではなく、プレースホルダドメイン ({0}{1}app.box.comなど) を使用して接続しようとします。 この状況は、サブドメインが [Box設定] に正しく表示されているにもかかわらず、基になる組織の構成が更新されていなかった場合に発生する可能性があります。
解決方法
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[Box設定] → [コンテンツ] で [Box Enterpriseのサブドメイン] を確認します。
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<companysubdomain>のみを入力してください (例: Box URLがhttps://cloud.app.box.comの場合はcloud)。 - 以下のようなURL全体は入力しないでください。
<companysubdomain.app.box.com><companysubdomain.com><www.companysubdomain.com>
- 設定を保存し、問題が発生している機能を再度試してください。
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- エラーが引き続き発生する場合、つまりメッセージに
{0}{1}app.box.comが含まれている場合は、[Box設定] → [認証] でBoxサービスアカウントを再接続します。- [再接続] をクリックします (まだ接続していない場合は接続します)。
- これにより、埋め込み機能で使用される、組織レベルのBox接続設定が更新されます。
- 再接続が完了したら、問題が発生している機能を再度試してください。
両方の手順を実行した後も問題が解決しない場合は、正確なエラーメッセージとブラウザのネットワークログを添付して、Boxサポートまでお問い合わせください。
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