問題
API経由でBoxに対する認証を行うと、「リダイレクトURIの不一致」エラーが発生します。 [詳細を表示] をクリックすると、影響を受けているリダイレクトURIが表示されます。
根本原因
最も多い原因として、認証リクエストのリダイレクトURIがアプリで設定されているリダイレクトURIと一致していないことが挙げられます。
解決手順
この問題を解決するには、アプリケーションコードで使用されているリダイレクトURLを変更して開発者コンソールのURLと厳密に一致させるか、Box開発者コンソールで対象のアプリケーションの [構成] タブにあるリダイレクトURLを更新します。
方法1: コードを更新する
方法1の場合は、アプリケーションコードを変更し、影響を受けるURLを、開発者コンソールのURLと厳密に一致するよう置き換えてください。
方法2: アプリを更新する
方法2の場合は、以下の手順に従ってください。
- アプリケーション所有者としてBoxにログインし、開発者コンソールページに移動します。
- アプリケーションをクリックし、[構成] タブに移動します。
- [OAuth 2.0リダイレクトURI] セクションまで下にスクロールします。
- 現在表示されているURLを更新します。 [リダイレクトURI] フィールドに適切なURLを追加します。上記の例では、http://localhost:3000/callbackとなります。
注
[リダイレクトURI] セクションが表示されない場合は、アプリがOAuth 2.0認証アプリではないため、別の方法で認証する必要があります。 次のステップについては、こちらのリソースを参照してください: https://developer.box.com/ja/guides/authentication