問題
更新後に、SalesforceサンドボックスのBoxフォルダコンポーネントでエラーが表示されます。
原因
Boxフォルダ/Salesforceレコードの関係は、SalesforceのFRUPと呼ばれるオブジェクトによって管理されます。 1つのFRUPレコードには、1つのBoxフォルダIDとそれに関連付けられたSalesforceのレコードIDが記録されます。 また、個々のユーザー (BoxとSalesforce) とそのフォルダ/レコード関係へのアクセスもFRUPレコードによって追跡されます。
更新では、本番組織に存在するSalesforceレコードIDの値を使用して、サンドボックスにFRUPオブジェクトが作成されるため、 サンドボックスのレコードに存在するBoxフォルダコンポーネントで予期しない動作が発生します。
解決方法
この統合には、本番環境のレコードのFRUPに関連するFRUPの作成を自動化する機能は用意されていませんが、サンドボックスの既存のBoxデータすべてを削除する機能は用意されています。 したがって、本番組織に存在するデータと完全に一致することはありませんが、引き続き、サンドボックスでBox for Salesforce統合の機能をテストすることができます。
サンドボックスからすべてのBox設定データを削除するには、[Box設定] タブ > [詳細設定] > [詳細設定] に移動し、[このサンドボックス内のすべてのBoxデータを削除] ボタンをクリックします。