問題
Box for NetSuite統合の1人のユーザーの [Box Content] タブで、「There was an issue with the Box SuiteApp (Box SuiteAppで問題が発生しました)」エラーが表示されることがあります。
原因
Boxの管理対象ユーザーとNetSuiteの従業員の間の関連付けは、「Box Account Association」と呼ばれるレコードタイプで定義されています。 このタイプのレコードは1つだけ存在する必要があります。 このタイプのレコードが存在しない場合、または当該のBox管理対象ユーザーかNetSuite従業員に関連する複数のレコードが存在する場合に、上記のエラーが表示されます。
解決方法
この統合でNetSuiteユーザーが適切なBoxユーザーIDに関連付けられているかどうかを確認します。 このユーザーIDをBoxで見つけて、Box for NetSuiteでその特定のユーザーIDの既存の関連付けを確認する方法を以下に示します。
- box.comにログインして、このユーザーのユーザーIDを収集します。
- ウェブアプリの右上にあるプロフィールアイコンをクリックします。
- [アカウント設定] を選択します。
- 下にスクロールし、 [アカウントID] を書き留めます。 これは、BoxユーザーIDと同じ意味になります。
- NetSuiteで、[Customization] > [Lists, Records & Fields] > [Record Types] に移動します。
- [Box Account Association] (リスト) をクリックします。
- そのリストのページで、[Search] をクリックします。
- BoxユーザーIDでの検索を許可する保存済みの検索が存在しない場合は、作成します。
- [Use Advanced Search] をクリックします。
- [Box User ID] でフィルタをかけます。
- 検索を実行します。
1つのBoxユーザーIDに対して「Box Account Association」レコードが複数存在する場合は、無関係の関連付けを削除します。
「Box Account Association」で当該のNetSuite従業員IDの検索を実行するには、上記の手順を繰り返します。 1つのNetSuite従業員IDに対して「Box Account Association」レコードが複数存在する場合は、無関係の関連付けを削除します。
いずれのIDにもBoxアカウントの関連付けが存在しない場合は、以下の手順に従って作成します。
- NetSuiteで、[Employees] > [Employees] に移動します。
- 自分の名前の横にある [View] をクリックします。
- [Employee] レコードページのURLで、
?id=の後ろの数字を書き留めます。 これがNetSuiteユーザーIDになります。
- [Customization] > [Lists, Records & Fields] > [Record Types] に移動します。
- [Box Account Association] (リスト) をクリックします。
- [New Box Account Association] をクリックします。
- それぞれのフィールドにNetSuiteユーザーIDとBoxユーザーIDを入力します。 [Save] をクリックします。