[アプリアクセスレベル] の設定は、JWT認証およびクライアント資格情報許可のカスタムアプリのみに適用されます。
また、カスタムアプリ設定の中には、特定のアプリアクセスレベルが必要なものもあります。 特定のカスタムアプリ設定に特定のアプリアクセスレベルの設定が必要かどうかを判断するには、スコープのドキュメントを確認してください。
[アプリアクセスのみ] と [アプリ + Enterpriseアクセス]
アプリケーションのアクセスレベルによって、アプリからアクセスできるユーザーとコンテンツが決まります。 デフォルトでは、アプリケーションが正常に操作できるのは、そのサービスアカウントと任意のApp Userのコンテンツだけです。 企業の既存の管理対象ユーザーやアプリ自体が作成していないグループにアクセスするには、開発者コンソールの [構成] タブにある [アプリケーションアクセス] の設定に移動し、[アプリ + Enterpriseアクセス] に設定します。 そうしないと、当該の管理対象ユーザーやグループへのアクセスはブロックされます。
問題
as-userヘッダーまたはユーザーアクセストークン機能を使用し、BoxアカウントとしてAPIコールを実行することはできません。
エラー
{"type":"error","status":403,"code":"access_denied_insufficient_permissions","help_url":"http:\/\/developers.box.com\/docs\/#errors","message":"Access denied - insufficient permission","request_id":"abcd1efgh2ijkl3m"}
原因
as-userヘッダーまたはユーザーアクセストークンを使用すると、別のBoxアカウントとしてAPIコールを実行できるため、カスタムアプリではBox Enterpriseにアクセスできる必要があります。
解決方法
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Boxカスタムアプリの [アプリアクセスレベル] が [アプリ + Enterpriseアクセス] に設定されていることを確認します。
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カスタムアプリ設定の変更を保存します。
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Boxカスタムアプリを再承認します。
注
as-userヘッダーでは、共同管理者が別の共同管理者アカウントを使用したり、管理対象ユーザーアカウントが管理者/共同管理者アカウントを使用したりすることはできません。