Box for Salesforceユーザーが [Boxユーザー設定] タブからログインしようとすると、「This Box Account is already linked to Salesforce user: {salesforce login address}」というエラーメッセージが表示される場合があります。
根本原因
このエラーは、ログインに使用しようとしたBoxアカウントの資格情報に、エラーメッセージ内のSalesforceユーザーがすでに関連付けられていることを意味します。 1つのBoxアカウントを複数のSalesforceユーザーに関連付けることはできません。
解決方法
このエラーを解決するには、各Salesforceアカウントに異なるBoxアカウントを使用していることを確認する必要があります。
新しいSalesforceアカウントをBoxアカウントにリンクできるようにSalesforceアカウントとBoxアカウント間の既存の関連付けを解除する必要がある場合は、Salesforce開発者コンソールを使用してdeleteUserAssociationメソッドを実行します。
Classic UIの手順
- [Setup (設定)] > [Administer (管理)] > [Manage Users (ユーザーの管理)] > [Users (ユーザー)] に移動します。
- 当該ユーザーをクリックします。
- IDは、現在開いている [User Detail (ユーザーの詳細)] ページのURLに含まれており、ブラウザのアドレスバーで確認できます。
- 例: 「https://na1.salesforce.com/00530000000ibYc」というURLの場合、一意のSalesforceユーザーIDは「00530000000ibYc」です (Salesforceの参照記事)。
- 開発者コンソールを起動します (ウィンドウの右上で、自分の名前 > [Developer Console (開発者コンソール)] をクリックします)。
- [Debug (デバッグ)] > [Open Execute Anonymous Window (匿名実行ウィンドウを開く)] を選択します。
- その後、box.Toolkit.deleteUserAssociation('SFDC_User_ID');を実行します。
- 一重引用符を含め、末尾のセミコロンを忘れないようにしてください。
- ユーザーに再度Salesforceにログインしてもらい、[Box設定] に移動して、Boxアカウントにログインしてもらいます。
Lightning UIの手順
ユーザーのSalesforceユーザーID が必要になります。 これを取得するには、以下の手順に従います。
- グローバル検索バーでユーザーを検索します。
- [People (人)] でそのユーザーレコードをクリックします。
- URLは次のようになります: https://ap5.lightning.force.com/lightning/r/User/0057F000000ZXitQAG/view?0.source=alohaHeader
- 「0057F000000ZXit」が15文字のID、「0057F000000ZXitQAG」全体は18桁のIDとなります。
- 「0057F000000ZXit」が15文字のID、「0057F000000ZXitQAG」全体は18桁のIDとなります。
- ユーザーの値を書き留めます。
- クイックアクセスメニュー () をクリックします。
- [Developer Console (開発者コンソール)] をクリックします。
- [Debug (デバッグ)] > [Open Execute Anonymous Window (匿名実行ウィンドウを開く)] を選択します。
- その後、box.Toolkit.deleteUserAssociation('SFDC_User_ID');を実行します。
- 一重引用符を含め、末尾のセミコロンを忘れないようにしてください。
- スクリプトの実行時に「invalid id (無効なID)」というエラーが表示される場合は、ユーザーIDを取得する前に、手順3のURLの デコードが必要になることがあります。
- 例: ユーザーIDとして2F0053Z00000IVYkvがURLに表示され、エラーが発生している場合、 URLをデコードすると、ユーザーIDは0053Z00000IVYkvとなり、スクリプトが正常に実行されます。
platform_swarm_kb