SalesforceレコードでBoxフォルダにアクセスしようとすると、次のエラーが表示されます。
原因
このエラーには、以下の2つの原因が考えられます。
- 特定のSalesforceレコードに関連付けられているBoxフォルダが削除された。
- Boxユーザーが削除され、再作成された。
解決方法
最初のシナリオが原因の場合に、このエラーを解決するには、このエラーに関連する特定のフォルダ (オブジェクト/レコード) をBoxサービスアカウントのごみ箱から復元する必要があります。管理者は、Boxサービスアカウントにログインし、ごみ箱にアクセスすることで、エラーを引き起こしている特定のフォルダを復元できます。
Boxユーザーが削除されて再作成されている場合、このエラーを解決するには、Salesforce Developer Toolkitを使用して、古いBoxユーザーとレコードフォルダの関連付けを削除します。
- 影響を受けるユーザーのSalesforceユーザーIDを検索します。
- [Setup (設定)] > [Administer (管理)] > [Manage Users (ユーザーの管理)] > [Users (ユーザー)] に移動します。
- 影響を受けているユーザーを開きます。
- IDは、現在開いている [ユーザーの詳細] ページのURLに含まれており、ブラウザのURLで確認できます。 例: 「https://na1.salesforce.com/00530000000ibYc」というURLの場合、一意のSalesforceユーザーIDは「00530000000ibYc」です。
- ウィンドウの右上で、[自分の名前] > [Developer Console (開発者コンソール)] をクリックします。
- [Debug (デバッグ)] > [Open Execute Anonymous Window (匿名実行ウィンドウを開く)] を選択します。
- box.Toolkit.deleteUserAssociation('SFDC_User_ID');を実行します。
- 一重引用符が含まれていることを確認します。[SFDC_User_ID] を適切なIDに置き換え、スクリプトの最後にセミコロンが含まれていることを確認してください。
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