Issue
When attempting to invite a user to a shared folder after having your company email domain added to the collaboration allowed list (whitelist) operated by the user’s company, you may encounter an error message stating, “Invitations could not be sent to the following people because collaboration is restricted to their enterprise's collaboration allowed list.” This error prevents the invitation from being sent.
Root Cause
The email domain of the user who owns the item may be missing in the collaboration allowed list.
Resolution
Verify that the email domain of the user who owns the item is contained in the collaboration allowed list of the invited user.
Example
Consider the following scenario:
- Inviter: inviter@aaa.com (belongs to EID#123)
- Invitee: invitee@bbb.com (belongs to EID#456)
- Folder owner: owner@aaa.co.jp (belongs to EID#123)
- Target folder ID: 111222333
- EID#456 has collaboration allowlisting enabled
When inviter@aaa.com tries to invite invitee@bbb.com to the folder 111222333, collaboration invitation gets blocked in case the domain has not been added to the collaboration allowed list by EID#456.
In this case, the domain that needs to be added to the collaboration allowed list is "aaa.co.jp" - the email domain of the folder owner. Adding the email domain of the inviter "aaa.com" doesn't help unblock the collaboration invite.