Issue
Users are unable to log in to Box Drive, or experience delays in syncing folders and files after logging in.
Root Cause
If the proxy server in use does not allow access to the required hosts, communication with Box Drive may be blocked or disconnected.
Resolution
Contact the network administrator to ensure the necessary hosts are allowed.
Reference Information
If the following error message appears in the Box Drive logs, it is likely that communication with Box Drive is being blocked or disconnected.
2024-11-17 13:23:08.061 13800 INFO NetworkConnectivityC network_layer Request: head https://api.box.com/ping {} {}
2024-11-17 13:23:08.109 13800 INFO NetworkConnectivityC proxy_auth_https_conn Proxy connect error: OSError(b'Tunnel connection failed: 302, Found')
2024-11-17 13:23:08.109 13800 INFO NetworkConnectivityC network_layer Got a ProxyError so calling refresh_proxy_settings: ProxyAuthHTTPSConnectionPool(host='api.box.com', port=443): Max retries exceeded with url: /ping (Caused by ProxyError('Cannot connect to proxy.', OSError('Tunnel connection failed; Unsupported response status: 302')))
2024-11-17 13:23:08.109 13800 INFO NetworkConnectivityC proxy_settings_cache Proxy settings: {'https': 'http://<proxy server host>, 'http': 'http://<proxy server host>'}