Issue
When you invite a user to collaborate on a folder or a file, you may encounter one of the following symptoms:
The invited collaborator does not appear in the collaborator list, even though the invitation was successfully sent.
An unrecognized or different email address is displayed in the collaborator list instead of the email address you originally invited.
Root Cause
This behavior occurs because Box displays the user's primary email address in the collaborator list.
If you send a collaboration invitation to a user's secondary email address, their profile will appear in the collaborator list under their primary email address rather than the secondary email address you entered. This can make it appear as though the invited collaborator has disappeared or that an unauthorized email address has been invited to the item.
Resolution Steps
To verify if the collaborator has successfully joined, please perform the following checks:
- Confirm with the Collaborator: Contact the invited user and confirm if the unrecognized email address displayed in the collaborator list is indeed their primary Box email address associated with their secondary email alias.
- Verify Permissions and Invited date: Ensure you are viewing the correct item and the collaborator have the appropriate permissions and invited date in the collaborator list.
- If you still suspect an issue or cannot identify the user, please contact Box Support with the detailed information.