概要
Box for Salesforce統合でユーザーが繰り返しサインアウトされたり、1日に何度も再承認を求められたりする場合や、SalesforceからBoxにアクセスする際に「refused to connect (接続が拒否されました)」と表示される場合は、以下の手順に従い、一般的な原因を特定して解決してください。
根本原因
この現象は、SalesforceとBox間のOAuthセッションが中断されたり、持続できなくなったりした場合に発生します。 一般的な要因としては、ブラウザのセッション/Cookieの設定によりサイト間認証がブロックされている、Salesforceの [Box設定] でBox Enterpriseのサブドメインが入力されていないか間違っている、Salesforceのセッション/クリックジャッキングの設定が埋め込まれたBoxページに干渉しているなどが挙げられます。 ローカルのブラウザやプロファイルによってサードパーティのCookieがブロックされている場合やセッションデータがクリアされている場合、この問題の影響を受けるユーザーは1人だけの可能性があります。
解決手順
一般的な原因をすべて除外するために、以下の手順に従います。 各手順の後、影響を受けているユーザーに再承認とワークフローの再現を行ってもらい、問題が解決するかどうかを確認してください。
-
環境を確認する
- ユーザーが使用しているブラウザがサポートされていて、最新のバージョンであることを確認します。
- ユーザーがプライベート/シークレットモードを使用していないことを確認します。
-
ブラウザのCookie設定を確認する
- サードパーティのCookieやサイト間のCookieが許可されている (またはsalesforce.comとbox.comに対してブロックされていない) ことを確認します。
- 組織が拡張機能やグループポリシーを使用してCookieの制限を適用している場合は、
box.comとBox Enterpriseのサブドメインをホワイトリストに追加します。
-
SalesforceでBox Enterpriseのサブドメインを確認する
- Salesforceで、[Box設定] > [Advanced Setup (高度な設定)] > [Advanced Settings (詳細設定)] に移動します。
- [Box Enterprise Sub-Domain (Box Enterpriseのサブドメイン)] フィールドに自社のサブドメイン (例:
yourcompanysubdomain) が入力されていることを確認し、入力されていない場合は保存します。 - 詳細については、こちらのBoxサポートガイドを参照してください。
-
SalesforceセッションとVisualforceのクリックジャック保護を確認する
- Salesforceの [Setup (設定)] で、[Session Settings (セッションの設定)] に移動し、クリックジャック保護のオプションを確認します。
- カスタムVisualforceページまたはカスタム統合を使用している場合は、[Enable clickjack protection for customer Visualforce pages with headers disabled (ヘッダーが無効化されたVisualforceページのクリックジャック保護を有効化)] や類似の設定が有効になっているかどうかを確認します。(セキュリティポリシーに従って) これらを切り替えると、埋め込まれたコンテンツや再承認フローが影響を受ける可能性があります。
-
ローカルのプロファイルまたはネットワーク要因を除外する
- 新しいブラウザプロファイルまたは別のブラウザでテストして、問題がプロファイル固有のものかどうかを確認するようユーザーに依頼します。
- 可能な場合は、別のマシンやネットワーク (例: ホームネットワークやモバイルホットスポット) でテストして、セッションのクリアやサイト間トラフィックのブロックの原因となる企業のネットワークポリシーを除外します。
- 上記のいずれの手順でも問題が解決しない場合は、Box Product Supportまでお問い合わせください。
ユーザーアカウントを再承認する方法
- Salesforceのアプリケーションランチャーに移動し、Boxと入力します。
- [Box設定] に移動し、[Log In as a Box User(Boxユーザーとしてログイン)] の横にある [Connect(接続)] をクリックします。
- [Connect with Box(Boxに接続)] で [Reauthorize(再承認)] をクリックします。
- Boxの資格情報を入力するか、SSOが有効になっている組織の場合はSSOを使用して、Boxアカウントにログインします。