Box Drive provides user notifications if there are any issues saving your changes to Box. The Box Drive application interface lists the file and provides a brief description of the issue.
To find a list of any problem file notifications:
- Click the Box icon in your menu bar or system tray to open the Box Drive Search Bar.
- Click the Gear icon (lower right corner for Mac, top left corner for Windows) for more options, then click Error updating an item...
- All problem file notifications will be listed here. They should disappear automatically once you have resolved the issue. If they do not, and you believe you have already resolved the issue, you can click Retry All to manually retry your actions.
You will see the following errors due to lack of various permissions on a file or folder:
Action Failed: File Cannot Be Downloaded
Action Failed: File Download Restricted
Action Failed: File Is Locked on Box
Action Failed: File May Be Locked or in Use
Insufficient Permissions to Upload File
Read Only: Move Failed (Error Code: 02)
Read Only: Move Failed (Error Code: 03)
Read Only: Move/Rename Failed (Error Codes: 01 & 04)
Read Only: Rename Failed (Error Code: 05)
Read Only: Upload Failed (Error Code: 06)
Read Only: Upload Failed (Error Code: 07)
Action Failed: File Cannot Be Downloaded
Cause:
- If you do not have permissions to download a file from Box, you will not be able to download the file in Box Drive. You may also see this error if a download has failed for an unknown reason.
Resolution:
- Check your permissions on the item and reattempt the download. If you have marked a folder for offline access that you don't have download permissions in, make the folder online only again to clear the problem items.
Action Failed: File Download Restricted
Cause:
- If a collaborator has locked a file on Box and prevented downloads, you will not be able to download the file until it is unlocked.
Resolution:
- Unlock the file on Box and contact the collaborator who locked the file if necessary. Once this file is unlocked, try your action again.
Action Failed: File Is Locked on Box
Cause:
- If a collaborator has locked a file on Box, you will not be able to update the file until it is unlocked.
Resolution:
- Locate the file on Box, right-click and select Unlock File. Before the file is unlocked, you can view the name of the person who locked the file. Contact this person to coordinate your changes. Once this file is unlocked, try your action again.
Action Failed: File May Be Locked or in Use
Cause:
- The file you are trying to take action on has been locked by the local machine.
- The file might be in use by another application, or the computer administrator may have to unlock the file before you can access it.
Resolution:
- Close all other apps and restart Box Drive, then try again.
Insufficient Permissions to Upload File
Cause:
- In order to make an action on a file you must have Editor access or above.
Resolution:
- Check What are the different permission levels for collaborators? and verify that the file owner has granted the required permission for you to save the required file.
- If you are unable to act on a file because of permissions settings, alert the folder owner. Once you have the right permissions for this file, try your action again
- If you are unable to create content directly in the Box folder, confirm that your Admin has not restricted content creation in Enterprise Settings.
- Sometimes, another person may be editing your file in Box and you may not have the required permission to overwrite that file. In this case, save the file to another folder and restart the Box application.
- Sometimes, a local application (for example MS Word or Adobe Acrobat) may hold on to the file. Restart any local applications that may have opened the file, then manually re-save your file.
- If these fixes don’t work, then you may need to restart your computer. If you restart your computer and Box Drive is configured to start automatically, then this file will begin saving automatically.
Read Only: Move Failed (Error Code: 02)
Cause:
- You do not have sufficient permissions to move this file.
Resolution:
- Close the file, and Box Drive will move the file back to it's original location. If Drive fails to move the file back, move it back manually.
Read Only: Move Failed (Error Code: 03)
Cause:
- You do not have sufficient permissions to move this file.
Resolution:
- In order to recover the moved item and resolve the problem notification, copy the file into a folder that you own in Box, then delete the original.
Read Only: Move/Rename Failed (Error Codes: 01 & 04)
Cause:
- You do not have sufficient permissions to move or rename this file.
Resolution:
- Check with the file owner and request appropriate permissions.
Read Only: Rename Failed (Error Code: 05)
Cause:
- You do not have sufficient permissions to rename this file.
Resolution:
- Close the file and its original name will be restored automatically.
Read Only: Upload Failed (Error Code: 06)
Cause:
- Box Drive was unable to save your changes to the file because you lack sufficient permissions to make edits.
Resolution:
- Close the file, and any changes will be saved as a new copy on your desktop. Move this local copy into a folder that you own to save it to Box.
Read Only: Upload Failed (Error Code: 07)
Cause:
- You don't have sufficient permissions to edit this file.
Resolution:
- Check with the file owner and request appropriate permissions before trying again.