When trying to add a Secondary Email Address to your Box account, some users may see the error "there was an error while trying to add user@domain.com to your account".
Root Cause
You will receive this error if the email address you are trying to add is already associated with a Box account.
This error may also appear if you try to add a secondary email address more than once in a row.
Resolution Steps
If you are trying to add multiple addresses in a row, please allow at least 24 hours before performing the next operation.
If not, in order to resolve this issue, please contact Box Product Support. We will help confirm the reason for this error and free up your email address. Please open a case with the email address of your existing account and the email address you are trying to add.