When attempting to log in to Box (typically in SSO environment), a user may receive 1. "We've sent you a confirmation email" or 2. "ERR_TOO_MANY_REDIRECTS" error.
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We've sent you a confirmation email
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ERR_TOO_MANY_REDIRECTS
Root Cause
A user may get redirected to the email address confirmation page (screenshot #1) or get "ERR_TOO_MANY_REDIRECTS" error (screenshot #2) in case getting caught in redirection loop (due to bad cache/cookie or if Device Trust is enabled) when his/her email address has not been confirmed after signing up for a Box account.
This typically happens to a user whose Box account was provisioned by the admin during the time "SSO Required" is switched OFF and was later switched ON after that user account was provisioned. In this case, although the user can sign into Box via SSO, the user still needs to confirm his/her email address (which is why he/she gets redirected to the email confirmation page upon login).
Solution
To avoid getting redirected to the above page/error, you can either confirm the email address or reset the password of the Box account (not IdP).
- To resend confirmation email, you can click on "Click here to resend" button in the screenshot #1.
- To reset the password for your Box account, you can follow the steps in this article.
If you are getting "ERR_TOO_MANY_REDIRECTS", you may need to clear the cookie and cache in advance to performing the above.
Note: For users who were provisioned while the Admin had Silent mode switched ON, password reset may not help resolve the issue, and you need to confirm the email address. If you cannot confirm the email address due to "ERR_TOO_MANY_REDIRECTS" error, then the Admin can use Instant Login to login on your behalf. As the Admin logs in as your account and lands on the email address confirmation page (screenshot #1), the Admin can click on "Click here to resend" to resend the confirmation link to you, which you can then use to confirm your email address.