Issue
When attempting to transfer admin privileges on the Change Account Admin screen by copying and pasting an email address into the New Admin field and saving the changes, the following error message appears: “Failed to validate new admin user.”
The email address entered in the New Admin field belongs to a member within the same domain as the current Box admin.
Root Cause
This error occurs because the email address was copied and pasted into the New Admin field.
In New Admin, you need to manually enter a name or email address and select a user from the search results for user validation.
Resolution
On the Change Account Admin screen, enter the new admin’s name or email address directly to the New Admin field and select the correct email address from the search results.
When the name is entered
When the email address is entered
After selecting the email address, click Save Changes.