Issue
External collaborations may be deleted unexpectedly under the following conditions:
- When the permission level of an external collaboration is modified
- When the host user of an external collaboration is deleted
- When a free external collaboration user is invited into the tenant
Root Cause
This behavior occurs when the external collaborator’s email domain is not included in the allowlist defined under external collaboration restrictions.
The allowlist is validated not only when a new external collaborator is added, but also whenever the settings of an existing external collaboration are changed.
When the external collaborator’s email domain is not registered in the allowlist, the collaboration for the relevant external collaborator is deleted.
Resolution
Make sure that the email domain of the deleted external collaborator is registered in the organization’s external collaboration restriction allowlist.
If the domain is not registered, add it to the allowlist as appropriate.
Alternatively, register the user as an exception user permitted for external collaboration.
After adding the domain to the allowlist or registering the exception user, re-invite the external collaborator.
For more information, refer to https://support.box.com/hc/en-us/articles/4946326084755-Limit-collaboration-to-allowlisted-domains.