Issue
An attempt to change the admin’s secondary email address to the primary email address fails. The option Make Primary is not displayed next to the secondary email address under Account Settings > Account tab.
Root Cause
The option Make Primary is not displayed when the system prevents users from changing their primary email address due to one or more of the following settings:
- SSO Required is enabled under Admin Console > Enterprise Settings > User Settings tab.
- "Prevent users from changing their primary email address" is enabled under Admin Console > Enterprise Settings > Security tab > Signup and Login > User email/login.
Resolution
To display Make Primary, temporarily disable both SSO Required and Prevent users from changing their primary email address.
To change the secondary email address to the primary email address, follow the steps below. The secondary email address must be verified beforehand.
- Navigate to Admin Console > Enterprise Settings > User Settings tab, disable SSO Required.
- Navigate to Admin Console > Enterprise Settings > Security tab > Signup and Login > User email/login, disable Prevent users from changing their primary email address.
- Go to Account Settings > Account tab, and click the option Make Primary next to the secondary email address.
- If necessary, update the email address on the IdP side to match the new primary email address.
- Confirm that SSO login is successful with the new primary email address.
- If needed, re-enable SSO Required by referring to step 1.
- If needed, re-enable Prevent users from changing their primary email address by referring to step 2.