問題
Box DriveがインストールされているPCでOutlookの使用中に、「フォルダを開けません [ファイル名] を開けませんでした。 もう一度やり直してください。」というBoxからのエラーメッセージが大量に表示されました。
根本原因
何らかのプロセスがBox Driveのフォルダへ大量にアクセスし、処理しきれずにエラーとなっています。
解決方法
お客様がすぐに問題を軽減できるようにBoxでできる対応として、原因となっているプロセスを特定し、プロセス名をレジストリに追加することで、 そのプロセスがBox Driveのフォルダへアクセスしないように設定できます。
問題を起こしているプロセスを特定する方法 (Windows)
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C:\Users\<UserName>\Box\Box\Logs\配下にあるBox_Streemと接頭辞のつくファイル (例: Box_Streem_1_yyyy-mm-dd.log) のうち、事象が発生した日時のファイルを開きます。
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事象発生日時に大量にアクセスしているプロセスがあるか確認します。 同じプロセス (例: WmiPrvSE.exe) が大量にアクセスしている場合、以下のようなログの行が多数表示されます。
yyyy-mm-dd 23:13:19.700 INFO 0x00003dac [winfs:573][onGetFileInfo] [WmiPrvSE.exe] "\SampleFolder"
yyyy-mm-dd 23:14:19.700 INFO 0x000037ec [winfs:453][onOpenFile] [WmiPrvSE.exe] "\SampleFolder", shareMode: 0x7, desiredAccess: 0x100001
yyyy-mm-dd 23:14:19.700 INFO 0x00003da8 [winfs:494][onCloseFile] [WmiPrvSE.exe] "\SampleFolder"
該当するプロセスを特定できない場合は、弊社サポートにお問い合わせください。
プロセス名をレジストリに追加する方法
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Box Driveを終了します。
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レジストリエディタを使用して、HKEY_LOCAL_MACHINE\SOFTWARE\Box\Boxに移動します。
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BannedProcessNamesという複数行文字列値 (REG_MULTI_SZ) を新規作成します (存在しない場合)。
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BannedProcessNamesをダブルクリックし、プロセス名 (例: WmiPrvSE.exe) を追加します。
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レジストリエディタを閉じます。
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Box Driveを起動します。