問題
Box Driveにログインできない、またはログイン後にフォルダやファイルの同期が遅延する。
根本原因
利用中のプロキシサーバーが接続に必要なホストを許可していない場合、Box Driveの通信がブロックまたは切断されることがあります。
解決方法
ネットワーク管理者に連絡し、必要なホストを許可してください。
参考情報
Box Driveのログで以下のようなエラーが出力される場合は、Box Driveの通信がブロックまたは切断されていると考えられます。
2024-11-17 13:23:08.061 13800 INFO NetworkConnectivityC network_layer Request: head https://api.box.com/ping {} {}
2024-11-17 13:23:08.109 13800 INFO NetworkConnectivityC proxy_auth_https_conn Proxy connect error: OSError(b'Tunnel connection failed: 302, Found')
2024-11-17 13:23:08.109 13800 INFO NetworkConnectivityC network_layer Got a ProxyError so calling refresh_proxy_settings: ProxyAuthHTTPSConnectionPool(host='api.box.com', port=443): Max retries exceeded with url: /ping (Caused by ProxyError('Cannot connect to proxy.', OSError('Tunnel connection failed; Unsupported response status: 302')))
2024-11-17 13:23:08.109 13800 INFO NetworkConnectivityC proxy_settings_cache Proxy settings: {'https': 'http://<proxy server host, 'http': 'http://<proxy server host'}