問題
- Box DriveからBox NotesやBox Canvasファイルを開こうとすると、以下のメッセージが表示され、ファイルが開けない。
- WindowsのスタートメニューからBox Driveを起動しようとすると、以下のメッセージが表示され、起動できない。
根本原因
何らかの問題が発生してBox Driveのレジストリが欠損している場合、Box Driveが修復を行います。
以下のような原因が考えられます。
- Windows UpdateによってWindowsが更新された際、アプリケーションに必要なレジストリが移行されなかった。
- セキュリティツールによってレジストリが削除された。
解決方法
- Windowsイベントログを開き、エラーが表示された時刻の直前に、リソースが見つからないことを示すエラーが出力されていることを確認します。
リソースが見つからないことを示すエラー例:
製品 '{CB271E20-6FA7-42C7-838A-XXXXXXXXXXXX}'、機能 'ProductFeature'、コンポーネント '{DE4BE308-36B5-4F2D-BD3D-XXXXXXXXXXXX}' の検出に失敗しました。 リソース 'HKEY_LOCAL_MACHINE(64)\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\streem.exe\GlobalFlag' がありません。 - 以下のいずれかの方法で対応します。
- 「Please wait while Windows configures Box」のメッセージに従って、Box Driveを修復します。
- 1.で確認したレジストリを手動で追加します。 または、問題が発生していないWindows端末のレジストリと比較して、必要な値を確認します。